FAQs

FAQ/029 KAM-500: Why is the green LED on my chassis blinking?

August 18, 2014

This is a sign that there is a malfunction in the system (not necessary in that chassis).

Some steps for investigating the problem are as follows:

  1. Remove all the modules from the chassis and check the power lead and that 28V does not flick. The chassis can operate with an input voltage varying from +18V up to 40V. If the LED flickers without any modules in it and the 28V is stable then the chassis should be returned to Curtiss-Wright through the RMA process by sending a mail to acra-rma@curtisswright.com
     
  2. If the above is good, then replace the modules back into the chassis one at a time starting with the controller module such as the KAD/BCU/101 or KAD/BCU/105. Power up the chassis as each module is added to confirm if the LED is blinking. If the LED flickers after one of the modules is placed into the chassis then this module is faulty and should be returned to Curtiss-Wright through the RMA process at the address given above.
     
  3. If all the modules and chassis are good then the connectors on each module should be connected one by one until the faulty connection is found – in this instance, the cabling will need to be verified.

Share This Article

  • Share on Linkedin
  • Share on Twitter
  • Share on Facebook
  • Share on Google+
Connect With Curtiss-Wright Connect With Curtiss-Wright Connect With Curtiss-Wright
Sales

CONTACT SALES

Contact our sales team today to learn more about our products and services.

YOUR LOCATION

PRODUCT INFORMATION

Support

GET SUPPORT

Our support team can help answer your questions - contact us today.

REQUEST TYPE

SELECT BY

SELECT Topic